Qu'est-ce qui fait planter iMovie 11 lors de l'exportation d'un projet?


1

Je fais un court métrage avec iMovie.

De temps en temps (plus d'une fois par jour), je l'exporte au format moyen.

Je l'ai fait avec ma dernière version, puis j'ai affiné la vidéo et, lors de la réexportation, iMovie a commencé à planter.

Après beaucoup de piratage, de lecture (this great post for instance , qui donne de multiples solutions très utiles), j'ai compris que la cause était une vidéo corrompue .

Je plante probablement dans la partie où j'ai inclus une vidéo produite avec iMovie lui-même.Donc, je crée un projet temporaire avec iMovie et je l'exporte pour utiliser la vidéo exportée dans mon projet MAIN.

Je l'ai enlevé et maintenant ça marche.Si je l'inclus de nouveau, il se bloque parfois, et c'est ce qui est étrange: je n'ai jamais changé cette vidéo, et lorsque je l'inclus de nouveau, le projet s'exporte bien, parfois non (cela semble un problème non reproductible! Fou!) .

J'ai donc les questions suivantes:

  1. est-il possible de "réparer" la vidéo qui fait planter le projet?

  2. Y a-t-il moyen de comprendre, à partir du rapport d'erreur, QUELLE A ÉTÉ LA PARTIE CAUSANT L'ACCIDENT?

  3. iMovie est génial mais je pense que c'est encore un jouet.Ainsi, si j'achète le final cut pro x , puis-je importer des vidéos iMovie sans devenir fou?

-- METTRE À JOUR --

Les solutions suivantes ne sont pas possibles:

  • Suppression du titre "organique" (je ne l'utilise pas)
  • nettoyer l'entrée de préférences dans le dossier de la bibliothèque (com.apple.iMovieApp.plist), je l'ai déjà essayée
2

Vous pouvez essayer de convertir la vidéo défunte en un codec différent.Utilisez quelque chose comme Lossless, comme ProRes, si vous le pouvez, ou Motion JPEG.Puis replacez le clip dans votre projet.

J'ai eu ce problème once in FCP7 for about a week .Cela n’a pas disparu tant que j’ai réenregistré cette vidéo (ce qui était douloureux, mais faisable dans mon cas).Je ne suggérerais cependant pas une solution aussi radicale dans votre cas.Il y a beaucoup de choses que vous pouvez encore essayer.Lire le post lié.Ce que j’ai fait était essentiellement: "contourner ou forcer la conversion des supports à différentes étapes de la production".

Vous pouvez également ouvrir la console et consulter le journal lorsque l'application se bloque.Cela donne normalement des indications sur ce qui se passe à l’arrière-plan.

  0

Avez-vous des suggestions pour un bon convertisseur (gratuit c'est mieux!)?Merci 11 févr.. 132013-02-11 09:12:05

+1

Oui, essayez [HandBrake] (http://handbrake.fr/) ou [Adapter] (http://www.macroplant.com/adapter/) pour la conversion du "produit final" et [MPEG Streamclip] (http: //www.squared5.com/) pour la conversion "en production" (ProRes, Animation, MJPEG). 11 févr.. 132013-02-11 12:58:35

  0

Zett, comment pouvez-vous obtenir des indices dans le journal?toute suggestion?Il me semble que cela donne beaucoup d’informations sur les threads, les bibliothèques ... mais pas beaucoup d’indications sur le lieu où le problème est survenu (le fait d’avoir l’heure exacte à laquelle le problème a été généré nous serait très utile). 11 févr.. 132013-02-11 13:21:59

  0

Regardez à gauche où il est écrit '~/Library/Logs' et User Diagnostic Reports.Je suppose qu'il y a quelque chose quelque part à l'intérieur.Sinon, vous pouvez toujours saisir le nom de l'application dans le champ de recherche. 11 févr.. 132013-02-11 14:01:12

  0

Je pense avoir trouvé le problème !!!!Cela n'a rien à voir avec la vidéo.C'est le lettrage.Un lettrage le fait planter!La bonne nouvelle est qu'il se bloque également lorsque vous le lisez à partir de l'éditeur iMovie. Vous pouvez donc savoir que cela ne fonctionne pas avant de l'exporter. 12 févr.. 132013-02-12 09:38:18

  0

Hé, content que vous ayez trouvé le problème!J'espère que vous pourrez réparer votre vidéo bientôt.:RÉ 12 févr.. 132013-02-12 14:33:47


-1

J'ai résolu le même problème en supprimant toutes les animations de mon introduction.J'espère que cela est utile pour les problèmes futurs.